summaryrefslogtreecommitdiffstats
path: root/tools/test/perform/CMakeLists.txt
diff options
context:
space:
mode:
authorRay Lu <songyulu@hdfgroup.org>2018-11-15 15:43:46 (GMT)
committerRay Lu <songyulu@hdfgroup.org>2018-11-15 15:43:46 (GMT)
commite07d097da16a69cdd3d0d305595b241e6cf39f60 (patch)
tree01f90d465371c02fe22c6b25d19f6e6abe0824be /tools/test/perform/CMakeLists.txt
parent73f881a8385fffc7b48f3c2ec3ba538425966cbb (diff)
parentcd13d24e5140578a880aebe4e2d8b899179d0870 (diff)
downloadhdf5-e07d097da16a69cdd3d0d305595b241e6cf39f60.zip
hdf5-e07d097da16a69cdd3d0d305595b241e6cf39f60.tar.gz
hdf5-e07d097da16a69cdd3d0d305595b241e6cf39f60.tar.bz2
Merge pull request #1316 in HDFFV/hdf5 from ~SONGYULU/hdf5_ray:bugfix/HDFFV-10601-issues-with-chunk-cache-hash to develop
* commit 'cd13d24e5140578a880aebe4e2d8b899179d0870': HDFFV-10601: I added error checking to the HDF5 functions. HDFFV10601: Adding performance test to verify the improvement. HDFFV-10601: I changed to a better way to calculate the number of chunks in a dataset. HDFFV-10601 Issues with chunk cache hash value calcuation:
Diffstat (limited to 'tools/test/perform/CMakeLists.txt')
-rw-r--r--tools/test/perform/CMakeLists.txt10
1 files changed, 10 insertions, 0 deletions
diff --git a/tools/test/perform/CMakeLists.txt b/tools/test/perform/CMakeLists.txt
index fa41608..14abdec 100644
--- a/tools/test/perform/CMakeLists.txt
+++ b/tools/test/perform/CMakeLists.txt
@@ -51,6 +51,16 @@ TARGET_C_PROPERTIES (iopipe STATIC)
target_link_libraries (iopipe PRIVATE ${HDF5_LIB_TARGET} ${HDF5_TOOLS_LIB_TARGET})
set_target_properties (iopipe PROPERTIES FOLDER perform)
+#-- Adding test for chunk_cache
+set (chunk_cache_SOURCES
+ ${HDF5_TOOLS_TEST_PERFORM_SOURCE_DIR}/chunk_cache.c
+)
+add_executable (chunk_cache ${chunk_cache_SOURCES})
+target_include_directories(chunk_cache PRIVATE "${HDF5_SRC_DIR};${HDF5_BINARY_DIR};$<$<BOOL:${HDF5_ENABLE_PARALLEL}>:${MPI_C_INCLUDE_DIRS}>")
+TARGET_C_PROPERTIES (chunk_cache STATIC)
+target_link_libraries (chunk_cache PRIVATE ${HDF5_LIB_TARGET} ${HDF5_TOOLS_LIB_TARGET})
+set_target_properties (chunk_cache PROPERTIES FOLDER perform)
+
#-- Adding test for overhead
set (overhead_SOURCES
${HDF5_TOOLS_TEST_PERFORM_SOURCE_DIR}/overhead.c