summaryrefslogtreecommitdiffstats
path: root/utils/CMakeLists.txt
diff options
context:
space:
mode:
authorAllen Byrne <50328838+byrnHDF@users.noreply.github.com>2021-10-21 21:09:09 (GMT)
committerGitHub <noreply@github.com>2021-10-21 21:09:09 (GMT)
commit25ef191f433f0b90cd691d6481e6259ef7f5bc65 (patch)
tree7d848a023f120fa1ba81caddf998df2c12af2fb8 /utils/CMakeLists.txt
parent9ad1d9073c2750d7675ef7296e6ad80d50fbdc0f (diff)
downloadhdf5-25ef191f433f0b90cd691d6481e6259ef7f5bc65.zip
hdf5-25ef191f433f0b90cd691d6481e6259ef7f5bc65.tar.gz
hdf5-25ef191f433f0b90cd691d6481e6259ef7f5bc65.tar.bz2
1.12 Merge Move test utilities to utils/test folder #1109 (#1110)
* Merge Move test utilities to utils/test folder #1109 * Merge Correct shell tests and c++ flag warning * Fix typo
Diffstat (limited to 'utils/CMakeLists.txt')
-rw-r--r--utils/CMakeLists.txt9
1 files changed, 8 insertions, 1 deletions
diff --git a/utils/CMakeLists.txt b/utils/CMakeLists.txt
index 2d5626e..7c263d1 100644
--- a/utils/CMakeLists.txt
+++ b/utils/CMakeLists.txt
@@ -1,4 +1,11 @@
cmake_minimum_required (VERSION 3.10)
project (HDF5_UTILS C)
-add_subdirectory (mirror_vfd)
+if (BUILD_TESTING)
+ add_subdirectory (test)
+endif ()
+
+option (HDF5_BUILD_UTILS "Build HDF5 Utils" ON)
+if (HDF5_BUILD_UTILS)
+ add_subdirectory (mirror_vfd)
+endif ()