summaryrefslogtreecommitdiffstats
path: root/utils/CMakeLists.txt
diff options
context:
space:
mode:
authorAllen Byrne <50328838+byrnHDF@users.noreply.github.com>2021-10-20 13:25:06 (GMT)
committerGitHub <noreply@github.com>2021-10-20 13:25:06 (GMT)
commit6d4d0fb13db06895fc6ea5f98ae0b79b44aa98af (patch)
treec64c4f80838302fe4291028f65ab40c9b91900dd /utils/CMakeLists.txt
parentc196bf98eb7fe71c262e88b0227ea81906b9dbcf (diff)
downloadhdf5-6d4d0fb13db06895fc6ea5f98ae0b79b44aa98af.zip
hdf5-6d4d0fb13db06895fc6ea5f98ae0b79b44aa98af.tar.gz
hdf5-6d4d0fb13db06895fc6ea5f98ae0b79b44aa98af.tar.bz2
Move test utilities to utils/test folder (#1109)
* Move test utilities to utils/test folder * Fix makefile assignment * Add new dir * add new folder * Correct copied makefile * Fix dir typo * Add missing include dir * Remove unnecessary lib link * Correct dependent dirs * Fix conditional checks * Disable test if not built * fix path to executable * Use fixture for swmr_vfd check * Add release note * Correct shell tests and c++ flag warning * Update autotools c++ warning * Fix typo
Diffstat (limited to 'utils/CMakeLists.txt')
-rw-r--r--utils/CMakeLists.txt9
1 files changed, 8 insertions, 1 deletions
diff --git a/utils/CMakeLists.txt b/utils/CMakeLists.txt
index 2d5626e..7c263d1 100644
--- a/utils/CMakeLists.txt
+++ b/utils/CMakeLists.txt
@@ -1,4 +1,11 @@
cmake_minimum_required (VERSION 3.10)
project (HDF5_UTILS C)
-add_subdirectory (mirror_vfd)
+if (BUILD_TESTING)
+ add_subdirectory (test)
+endif ()
+
+option (HDF5_BUILD_UTILS "Build HDF5 Utils" ON)
+if (HDF5_BUILD_UTILS)
+ add_subdirectory (mirror_vfd)
+endif ()