summaryrefslogtreecommitdiffstats
path: root/utils/Makefile.am
diff options
context:
space:
mode:
authorAllen Byrne <50328838+byrnHDF@users.noreply.github.com>2021-10-25 14:27:44 (GMT)
committerGitHub <noreply@github.com>2021-10-25 14:27:44 (GMT)
commit9d296c30e57105eedd3fd747c32d4ec1c9c2494d (patch)
treecf9729e211bc34514cb06041e0fdd27a97d287c6 /utils/Makefile.am
parent8124798cba9292ecdbf4211e3eecbdd40b2bdda2 (diff)
downloadhdf5-9d296c30e57105eedd3fd747c32d4ec1c9c2494d.zip
hdf5-9d296c30e57105eedd3fd747c32d4ec1c9c2494d.tar.gz
hdf5-9d296c30e57105eedd3fd747c32d4ec1c9c2494d.tar.bz2
1.10 Merge Move test utilities to utils/test folder #1109 (#1111)
* Merge Move test utilities to utils/test folder #1109 * Merge Correct shell tests and c++ flag warning * Fix typo
Diffstat (limited to 'utils/Makefile.am')
-rw-r--r--utils/Makefile.am14
1 files changed, 13 insertions, 1 deletions
diff --git a/utils/Makefile.am b/utils/Makefile.am
index 288da37..876dfb1 100644
--- a/utils/Makefile.am
+++ b/utils/Makefile.am
@@ -20,7 +20,19 @@ include $(top_srcdir)/config/commence.am
CONFIG=ordered
+if BUILD_TESTS_CONDITIONAL
+ TESTUTIL_DIR =test
+else
+ TESTUTIL_DIR=
+endif
+
+if MIRROR_VFD_CONDITIONAL
+ MIRROR_VFD_DIR = mirror_vfd
+else
+ MIRROR_VFD_DIR=
+endif
+
# All subdirectories
-SUBDIRS=mirror_vfd
+SUBDIRS=$(MIRROR_VFD_DIR) $(TESTUTIL_DIR)
include $(top_srcdir)/config/conclude.am