summaryrefslogtreecommitdiffstats
path: root/utils/Makefile.am
diff options
context:
space:
mode:
authorAllen Byrne <50328838+byrnHDF@users.noreply.github.com>2021-10-20 13:25:06 (GMT)
committerGitHub <noreply@github.com>2021-10-20 13:25:06 (GMT)
commit6d4d0fb13db06895fc6ea5f98ae0b79b44aa98af (patch)
treec64c4f80838302fe4291028f65ab40c9b91900dd /utils/Makefile.am
parentc196bf98eb7fe71c262e88b0227ea81906b9dbcf (diff)
downloadhdf5-6d4d0fb13db06895fc6ea5f98ae0b79b44aa98af.zip
hdf5-6d4d0fb13db06895fc6ea5f98ae0b79b44aa98af.tar.gz
hdf5-6d4d0fb13db06895fc6ea5f98ae0b79b44aa98af.tar.bz2
Move test utilities to utils/test folder (#1109)
* Move test utilities to utils/test folder * Fix makefile assignment * Add new dir * add new folder * Correct copied makefile * Fix dir typo * Add missing include dir * Remove unnecessary lib link * Correct dependent dirs * Fix conditional checks * Disable test if not built * fix path to executable * Use fixture for swmr_vfd check * Add release note * Correct shell tests and c++ flag warning * Update autotools c++ warning * Fix typo
Diffstat (limited to 'utils/Makefile.am')
-rw-r--r--utils/Makefile.am14
1 files changed, 13 insertions, 1 deletions
diff --git a/utils/Makefile.am b/utils/Makefile.am
index 288da37..876dfb1 100644
--- a/utils/Makefile.am
+++ b/utils/Makefile.am
@@ -20,7 +20,19 @@ include $(top_srcdir)/config/commence.am
CONFIG=ordered
+if BUILD_TESTS_CONDITIONAL
+ TESTUTIL_DIR =test
+else
+ TESTUTIL_DIR=
+endif
+
+if MIRROR_VFD_CONDITIONAL
+ MIRROR_VFD_DIR = mirror_vfd
+else
+ MIRROR_VFD_DIR=
+endif
+
# All subdirectories
-SUBDIRS=mirror_vfd
+SUBDIRS=$(MIRROR_VFD_DIR) $(TESTUTIL_DIR)
include $(top_srcdir)/config/conclude.am