summaryrefslogtreecommitdiffstats
path: root/utils/Makefile.am
diff options
context:
space:
mode:
authorAllen Byrne <50328838+byrnHDF@users.noreply.github.com>2021-10-21 21:09:09 (GMT)
committerGitHub <noreply@github.com>2021-10-21 21:09:09 (GMT)
commit25ef191f433f0b90cd691d6481e6259ef7f5bc65 (patch)
tree7d848a023f120fa1ba81caddf998df2c12af2fb8 /utils/Makefile.am
parent9ad1d9073c2750d7675ef7296e6ad80d50fbdc0f (diff)
downloadhdf5-25ef191f433f0b90cd691d6481e6259ef7f5bc65.zip
hdf5-25ef191f433f0b90cd691d6481e6259ef7f5bc65.tar.gz
hdf5-25ef191f433f0b90cd691d6481e6259ef7f5bc65.tar.bz2
1.12 Merge Move test utilities to utils/test folder #1109 (#1110)
* Merge Move test utilities to utils/test folder #1109 * Merge Correct shell tests and c++ flag warning * Fix typo
Diffstat (limited to 'utils/Makefile.am')
-rw-r--r--utils/Makefile.am14
1 files changed, 13 insertions, 1 deletions
diff --git a/utils/Makefile.am b/utils/Makefile.am
index 288da37..876dfb1 100644
--- a/utils/Makefile.am
+++ b/utils/Makefile.am
@@ -20,7 +20,19 @@ include $(top_srcdir)/config/commence.am
CONFIG=ordered
+if BUILD_TESTS_CONDITIONAL
+ TESTUTIL_DIR =test
+else
+ TESTUTIL_DIR=
+endif
+
+if MIRROR_VFD_CONDITIONAL
+ MIRROR_VFD_DIR = mirror_vfd
+else
+ MIRROR_VFD_DIR=
+endif
+
# All subdirectories
-SUBDIRS=mirror_vfd
+SUBDIRS=$(MIRROR_VFD_DIR) $(TESTUTIL_DIR)
include $(top_srcdir)/config/conclude.am