summaryrefslogtreecommitdiffstats
path: root/utils/Makefile.am
diff options
context:
space:
mode:
authorScot Breitenfeld <brtnfld@hdfgroup.org>2021-11-23 19:15:30 (GMT)
committerGitHub <noreply@github.com>2021-11-23 19:15:30 (GMT)
commit2daa28652dc7823eac6a6fd2d7ad02d391585174 (patch)
tree0ff49369f51131e0232101faa5b9c3ae78755d0e /utils/Makefile.am
parent28d0a7b1b93e3918f3c8ee361af3280a2c9ee8a4 (diff)
downloadhdf5-2daa28652dc7823eac6a6fd2d7ad02d391585174.zip
hdf5-2daa28652dc7823eac6a6fd2d7ad02d391585174.tar.gz
hdf5-2daa28652dc7823eac6a6fd2d7ad02d391585174.tar.bz2
subfiling with selection IO (#1219)
Merged branch 'selection_io' into subfiling branch.
Diffstat (limited to 'utils/Makefile.am')
-rw-r--r--utils/Makefile.am14
1 files changed, 13 insertions, 1 deletions
diff --git a/utils/Makefile.am b/utils/Makefile.am
index 288da37..876dfb1 100644
--- a/utils/Makefile.am
+++ b/utils/Makefile.am
@@ -20,7 +20,19 @@ include $(top_srcdir)/config/commence.am
CONFIG=ordered
+if BUILD_TESTS_CONDITIONAL
+ TESTUTIL_DIR =test
+else
+ TESTUTIL_DIR=
+endif
+
+if MIRROR_VFD_CONDITIONAL
+ MIRROR_VFD_DIR = mirror_vfd
+else
+ MIRROR_VFD_DIR=
+endif
+
# All subdirectories
-SUBDIRS=mirror_vfd
+SUBDIRS=$(MIRROR_VFD_DIR) $(TESTUTIL_DIR)
include $(top_srcdir)/config/conclude.am