summaryrefslogtreecommitdiffstats
path: root/utils/test/Makefile.am
diff options
context:
space:
mode:
authorAllen Byrne <50328838+byrnHDF@users.noreply.github.com>2021-10-21 21:09:09 (GMT)
committerGitHub <noreply@github.com>2021-10-21 21:09:09 (GMT)
commit25ef191f433f0b90cd691d6481e6259ef7f5bc65 (patch)
tree7d848a023f120fa1ba81caddf998df2c12af2fb8 /utils/test/Makefile.am
parent9ad1d9073c2750d7675ef7296e6ad80d50fbdc0f (diff)
downloadhdf5-25ef191f433f0b90cd691d6481e6259ef7f5bc65.zip
hdf5-25ef191f433f0b90cd691d6481e6259ef7f5bc65.tar.gz
hdf5-25ef191f433f0b90cd691d6481e6259ef7f5bc65.tar.bz2
1.12 Merge Move test utilities to utils/test folder #1109 (#1110)
* Merge Move test utilities to utils/test folder #1109 * Merge Correct shell tests and c++ flag warning * Fix typo
Diffstat (limited to 'utils/test/Makefile.am')
-rw-r--r--utils/test/Makefile.am34
1 files changed, 34 insertions, 0 deletions
diff --git a/utils/test/Makefile.am b/utils/test/Makefile.am
new file mode 100644
index 0000000..164562f
--- /dev/null
+++ b/utils/test/Makefile.am
@@ -0,0 +1,34 @@
+#
+# Copyright by The HDF Group.
+# Copyright by the Board of Trustees of the University of Illinois.
+# All rights reserved.
+#
+# This file is part of HDF5. The full HDF5 copyright notice, including
+# terms governing use, modification, and redistribution, is contained in
+# the COPYING file, which can be found at the root of the source code
+# distribution tree, or in https://www.hdfgroup.org/licenses.
+# If you do not have access to either file, you may request a copy from
+# help@hdfgroup.org.
+##
+## Makefile.am
+## Run automake to generate a Makefile.in from this file.
+#
+# HDF5 Library Makefile(.in)
+#
+
+include $(top_srcdir)/config/commence.am
+
+# Include src and tools/lib directories
+AM_CPPFLAGS+=-I$(top_srcdir)/src -I$(top_srcdir)/test -I$(top_srcdir)/tools/lib -I$(top_srcdir)/utils/test
+
+# These are our main targets, the tools
+
+noinst_PROGRAMS=swmr_check_compat_vfd
+
+# Programs all depend on the hdf5 library, the tools library, and the HL
+# library.
+LDADD=$(LIBH5TEST) $(LIBHDF5)
+
+CHECK_CLEANFILES+=*.h5
+
+include $(top_srcdir)/config/conclude.am