summaryrefslogtreecommitdiffstats
path: root/utils/tools/CMakeLists.txt
diff options
context:
space:
mode:
authorrawarren <richardwarren2@verizon.net>2021-11-29 21:25:23 (GMT)
committerGitHub <noreply@github.com>2021-11-29 21:25:23 (GMT)
commit720ddb20f347f5ea4e573c44f64e1886d1dc1038 (patch)
treebdd32da8424488f6d10221518c08ed907ac2be18 /utils/tools/CMakeLists.txt
parent9cdc6d58bdc0a8bce74559d15fae1284beb82033 (diff)
downloadhdf5-720ddb20f347f5ea4e573c44f64e1886d1dc1038.zip
hdf5-720ddb20f347f5ea4e573c44f64e1886d1dc1038.tar.gz
hdf5-720ddb20f347f5ea4e573c44f64e1886d1dc1038.tar.bz2
Add support for parallel tools based on the 3rd party library mpiFileUtils (libMFU) … (#1177)
Adds tool h5dwalk and configure options to enable building it. Co-authored-by: Richard Warren <Richard.Warren@hdfgroup.org> Co-authored-by: github-actions <41898282+github-actions[bot]@users.noreply.github.com> Co-authored-by: Richard.Warren <richard.warren@jelly.ad.hdfgroup.org> Co-authored-by: Larry Knox <lrknox@hdfgroup.org>
Diffstat (limited to 'utils/tools/CMakeLists.txt')
-rw-r--r--utils/tools/CMakeLists.txt12
1 files changed, 12 insertions, 0 deletions
diff --git a/utils/tools/CMakeLists.txt b/utils/tools/CMakeLists.txt
new file mode 100644
index 0000000..49562d7
--- /dev/null
+++ b/utils/tools/CMakeLists.txt
@@ -0,0 +1,12 @@
+cmake_minimum_required (VERSION 3.12)
+project (HDF5_UTILS_TOOLS C)
+
+
+if (HDF5_BUILD_PARALLEL_TOOLS)
+ add_subdirectory (h5dwalk)
+endif()
+
+#-- Add the tests
+if (BUILD_TESTING)
+ add_subdirectory (test)
+endif()