summaryrefslogtreecommitdiffstats
path: root/utils/tools/test/h5dwalk/Makefile.am
diff options
context:
space:
mode:
authorScot Breitenfeld <brtnfld@hdfgroup.org>2021-12-06 16:39:22 (GMT)
committerGitHub <noreply@github.com>2021-12-06 16:39:22 (GMT)
commit65b1670861c62228cc68f98d4356edd180cfcb1f (patch)
treeefed6221a60ef59c96975e7af0b8fe15af772203 /utils/tools/test/h5dwalk/Makefile.am
parentad953381fd3bc980547cf1594dbb5be98a316477 (diff)
downloadhdf5-65b1670861c62228cc68f98d4356edd180cfcb1f.zip
hdf5-65b1670861c62228cc68f98d4356edd180cfcb1f.tar.gz
hdf5-65b1670861c62228cc68f98d4356edd180cfcb1f.tar.bz2
Merge branch 'selection_io' into selection_io_with_subfiling_vfd (#1265)
Diffstat (limited to 'utils/tools/test/h5dwalk/Makefile.am')
-rw-r--r--utils/tools/test/h5dwalk/Makefile.am43
1 files changed, 43 insertions, 0 deletions
diff --git a/utils/tools/test/h5dwalk/Makefile.am b/utils/tools/test/h5dwalk/Makefile.am
new file mode 100644
index 0000000..c32dd0f
--- /dev/null
+++ b/utils/tools/test/h5dwalk/Makefile.am
@@ -0,0 +1,43 @@
+#
+# Copyright by The HDF Group.
+# All rights reserved.
+#
+# This file is part of HDF5. The full HDF5 copyright notice, including
+# terms governing use, modification, and redistribution, is contained in
+# the COPYING file, which can be found at the root of the source code
+# distribution tree, or in https://www.hdfgroup.org/licenses.
+# If you do not have access to either file, you may request a copy from
+# help@hdfgroup.org.
+##
+## Makefile.am
+## Run automake to generate a Makefile.in from this file.
+#
+# HDF5 Library Makefile(.in)
+#
+
+include $(top_srcdir)/config/commence.am
+
+# Include src directory
+AM_CPPFLAGS+=-I$(top_srcdir)/src -I$(top_srcdir)/tools/lib
+
+install-examples:
+ @echo "Creating demo files" && \
+ . copy_demo_files.sh $(top_srcdir)/src
+
+bin_SCRIPTS:install-examples
+
+#test script and program
+TEST_SCRIPT=testh5dwalk.sh copy_demo_files.sh
+check_SCRIPTS=$(TEST_SCRIPT)
+SCRIPT_DEPEND=../../h5dwalk/h5dwalk$(EXEEXT)
+
+# Tell automake to clean h5redeploy script
+CLEANFILES=
+
+# These were generated by configure. Remove them only when distclean.
+DISTCLEANFILES=testh5dwalk.sh copy_demo_files.sh
+
+# All programs rely on hdf5 library and h5tools library
+LDADD=$(LIBH5TOOLS) $(LIBHDF5)
+
+include $(top_srcdir)/config/conclude.am