summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt11
1 files changed, 11 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 31cae2e..1c85965 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -813,6 +813,17 @@ if (DEFAULT_API_VERSION MATCHES "v114")
endif ()
#-----------------------------------------------------------------------------
+# Option to use 1.16.x API
+#-----------------------------------------------------------------------------
+if (NOT DEFAULT_API_VERSION)
+ set (DEFAULT_API_VERSION "v116")
+endif ()
+set (H5_USE_116_API_DEFAULT 0)
+if (DEFAULT_API_VERSION MATCHES "v116")
+ set (H5_USE_116_API_DEFAULT 1)
+endif ()
+
+#-----------------------------------------------------------------------------
# Include user macros
#-----------------------------------------------------------------------------
include (UserMacros.cmake)