summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index ac291fa..b6e0044 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -816,8 +816,13 @@ if (HDF5_ENABLE_THREADSAFE)
if (Threads_FOUND)
set (H5_HAVE_THREADSAFE 1)
endif ()
+else()
+ # Always check for pthreads for VFD SWMR (for now)
+ set (THREADS_PREFER_PTHREAD_FLAG ON)
+ find_package (Threads REQUIRED)
endif ()
+
#-----------------------------------------------------------------------------
# Option to build the map API
#-----------------------------------------------------------------------------