summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt20
1 files changed, 20 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 4cdb31c..b76f332 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -620,6 +620,26 @@ if (HDF5_USE_18_API_DEFAULT)
endif ()
#-----------------------------------------------------------------------------
+# Option to use 1.10.x API
+#-----------------------------------------------------------------------------
+option (HDF5_USE_110_API_DEFAULT "Use the HDF5 1.10.x API by default" OFF)
+set (H5_USE_110_API_DEFAULT 0)
+if (HDF5_USE_110_API_DEFAULT)
+ set (H5_USE_110_API_DEFAULT 1)
+ set (DEFAULT_API_VERSION "v110")
+endif ()
+
+#-----------------------------------------------------------------------------
+# Option to use 1.12.x API
+#-----------------------------------------------------------------------------
+option (HDF5_USE_112_API_DEFAULT "Use the HDF5 1.12.x API by default" ON)
+set (H5_USE_112_API_DEFAULT 0)
+if (HDF5_USE_112_API_DEFAULT)
+ set (H5_USE_112_API_DEFAULT 1)
+ set (DEFAULT_API_VERSION "v112")
+endif ()
+
+#-----------------------------------------------------------------------------
# Include user macros
#-----------------------------------------------------------------------------
include (UserMacros.cmake)