summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 6 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index cbb8163..037ec2f 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -790,8 +790,13 @@ if (BUILD_TESTING)
H5_SET_VFD_LIST()
endif ()
- option (HDF_TEST_EXPRESS "Control testing framework (0-3)" "0")
+ set (H5_TEST_EXPRESS_LEVEL_DEFAULT "3")
+ set (HDF_TEST_EXPRESS "${H5_TEST_EXPRESS_LEVEL_DEFAULT}"
+ CACHE STRING "Control testing framework (0-3) (0 = exhaustive testing; 3 = quicker testing)")
mark_as_advanced (HDF_TEST_EXPRESS)
+ if (NOT "${HDF_TEST_EXPRESS}" STREQUAL "")
+ set (H5_TEST_EXPRESS_LEVEL_DEFAULT "${HDF_TEST_EXPRESS}")
+ endif ()
enable_testing ()
include (CTest)