summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 0b3985b..ccab5d5 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -133,7 +133,9 @@ SET (HDF5_PERFORM_SRC_DIR ${HDF5_SOURCE_DIR}/perform)
SET (HDF5_F90_SRC_DIR ${HDF5_SOURCE_DIR}/fortran)
# set default prefix location
-SET (CMAKE_INSTALL_PREFIX "./hdf5" CACHE PATH "Install path prefix, prepended onto install directories")
+IF(CMAKE_INSTALL_PREFIX_INITIALIZED_TO_DEFAULT)
+ SET(CMAKE_INSTALL_PREFIX "hdf5" CACHE PATH "Install path prefix, prepended onto install directories" FORCE)
+ENDIF(CMAKE_INSTALL_PREFIX_INITIALIZED_TO_DEFAULT)
IF (NOT HDF5_INSTALL_BIN_DIR)
SET (HDF5_INSTALL_BIN_DIR bin)