summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt14
1 files changed, 5 insertions, 9 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index d142e0e..c29c1f6 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -734,15 +734,11 @@ endif ()
# see other find_package examples in /usr/share/cmake/Modules
option (HDF5_BUILD_SUBFILING "Build Parallel HDF5 Subfiling" OFF)
if (HDF5_BUILD_SUBFILING AND HDF5_ENABLE_PARALLEL)
- find_package(MERCURY REQUIRED)
- if (MERCURY_FOUND)
- message("Mercury include dir: ${MERCURY_INCLUDE_DIR}")
- include_directories(${MERCURY_INCLUDE_DIR})
- set (H5_HAVE_LIBMERCURY 1)
- set (H5_HAVE_MERCURY_H 1)
- set (CMAKE_REQUIRED_INCLUDES "${MERCURY_INCLUDE_DIR}")
- set (LINK_LIBS ${LINK_LIBS} ${MERCURY_LIBRARIES})
- endif()
+ message (STATUS "Setting up to use Mercury components")
+ include_directories(${HDF5_SRC_DIR}/mercury/include)
+ set (WITH_SUBFILING 1)
+ set (H5_HAVE_MERCURY_H 1)
+ set (CMAKE_REQUIRED_INCLUDES "${HDF5_SRC_DIR}/mercury/include")
endif()
#option (DEFAULT_API_VERSION "Enable v1.14 API (v16, v18, v110, v112, v114)" "v114")