summaryrefslogtreecommitdiffstats
path: root/HDF5Examples/FORTRAN/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'HDF5Examples/FORTRAN/CMakeLists.txt')
-rw-r--r--HDF5Examples/FORTRAN/CMakeLists.txt13
1 files changed, 13 insertions, 0 deletions
diff --git a/HDF5Examples/FORTRAN/CMakeLists.txt b/HDF5Examples/FORTRAN/CMakeLists.txt
new file mode 100644
index 0000000..72582fe
--- /dev/null
+++ b/HDF5Examples/FORTRAN/CMakeLists.txt
@@ -0,0 +1,13 @@
+cmake_minimum_required (VERSION 3.12)
+PROJECT (HDF5Examples_F90 C CXX Fortran)
+
+#-----------------------------------------------------------------------------
+# Build the Fortran Examples
+#-----------------------------------------------------------------------------
+add_subdirectory (${PROJECT_SOURCE_DIR}/H5D)
+add_subdirectory (${PROJECT_SOURCE_DIR}/H5G)
+add_subdirectory (${PROJECT_SOURCE_DIR}/H5T)
+
+if (H5_HAVE_PARALLEL AND HDF5_ENABLE_PARALLEL)
+ add_subdirectory (${PROJECT_SOURCE_DIR}/H5PAR)
+endif ()