summaryrefslogtreecommitdiffstats
path: root/HDF5Examples/FORTRAN/H5PAR/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'HDF5Examples/FORTRAN/H5PAR/CMakeLists.txt')
-rw-r--r--HDF5Examples/FORTRAN/H5PAR/CMakeLists.txt5
1 files changed, 2 insertions, 3 deletions
diff --git a/HDF5Examples/FORTRAN/H5PAR/CMakeLists.txt b/HDF5Examples/FORTRAN/H5PAR/CMakeLists.txt
index 98ef271..d3124a1 100644
--- a/HDF5Examples/FORTRAN/H5PAR/CMakeLists.txt
+++ b/HDF5Examples/FORTRAN/H5PAR/CMakeLists.txt
@@ -66,11 +66,10 @@ if (H5EX_BUILD_TESTING)
# Ensure that 24 is a multiple of the number of processes.
# The number 24 corresponds to SPACE1_DIM1 and SPACE1_DIM2 defined in ph5example.c
math(EXPR NUMPROCS "24 / ((24 + ${MPIEXEC_MAX_NUMPROCS} - 1) / ${MPIEXEC_MAX_NUMPROCS})")
-
foreach (example_name ${examples})
- if (${example_name} STREQUAL "ph5_hyperslab_by_col")
+ if (${example_name} STREQUAL "ph5_f90_hyperslab_by_row")
ADD_GREP_TEST (${example_name} 2)
- elseif (${example_name} STREQUAL "ph5_hyperslab_by_chunk" OR ${example_name} STREQUAL "ph5_hyperslab_by_pattern")
+ elseif (${example_name} STREQUAL "ph5_f90_hyperslab_by_chunk" OR ${example_name} STREQUAL "ph5_f90_hyperslab_by_pattern")
ADD_GREP_TEST (${example_name} 4)
else ()
ADD_GREP_TEST (${example_name} ${NUMPROCS})