summaryrefslogtreecommitdiffstats
path: root/HDF5Examples/FORTRAN/H5T/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'HDF5Examples/FORTRAN/H5T/Makefile.am')
-rw-r--r--HDF5Examples/FORTRAN/H5T/Makefile.am80
1 files changed, 80 insertions, 0 deletions
diff --git a/HDF5Examples/FORTRAN/H5T/Makefile.am b/HDF5Examples/FORTRAN/H5T/Makefile.am
new file mode 100644
index 0000000..79321f0
--- /dev/null
+++ b/HDF5Examples/FORTRAN/H5T/Makefile.am
@@ -0,0 +1,80 @@
+#
+# Copyright by The HDF Group.
+# Copyright by the Board of Trustees of the University of Illinois.
+# All rights reserved.
+#
+# This file is part of HDF5. The full HDF5 copyright notice, including
+# terms governing use, modification, and redistribution, is contained in
+# the files COPYING and Copyright.html. COPYING can be found at the root
+# of the source code distribution tree; Copyright.html can be found at the
+# root level of an installed copy of the electronic HDF5 document set and
+# is linked from the top-level documents page. It can also be found at
+# http://hdfgroup.org/HDF5/doc/Copyright.html. If you do not have
+# access to either file, you may request a copy from help@hdfgroup.org.
+##
+## Makefile.am
+## Run automake to generate a Makefile.in from this file.
+##
+
+noinst_PROGRAMS = h5ex_t_vlstring
+h5ex_t_vlstring_SOURCES = h5ex_t_vlstring.F90
+
+if FORTRAN_2003_CONDITIONAL_F
+
+noinst_PROGRAMS += h5ex_t_arrayatt_F03 h5ex_t_array_F03 h5ex_t_bitatt_F03 h5ex_t_bit_F03 \
+ h5ex_t_cmpdatt_F03 h5ex_t_cmpd_F03 h5ex_t_Cstring_F03 h5ex_t_enumatt_F03 \
+ h5ex_t_enum_F03 h5ex_t_floatatt_F03 h5ex_t_float_F03 h5ex_t_intatt_F03 h5ex_t_int_F03 \
+ h5ex_t_objrefatt_F03 h5ex_t_objref_F03 h5ex_t_opaqueatt_F03 h5ex_t_opaque_F03 \
+ h5ex_t_regrefatt_F03 h5ex_t_regref_F03 h5ex_t_stringCatt_F03 h5ex_t_stringC_F03 \
+ h5ex_t_string_F03 h5ex_t_vlenatt_F03 h5ex_t_vlen_F03
+
+h5ex_t_arrayatt_F03_SOURCES = h5ex_t_arrayatt_F03.F90
+h5ex_t_array_F03_SOURCES = h5ex_t_array_F03.F90
+h5ex_t_bitatt_F03_SOURCES = h5ex_t_bitatt_F03.F90
+h5ex_t_bit_F03_SOURCES = h5ex_t_bit_F03.F90
+h5ex_t_cmpdatt_F03_SOURCES = h5ex_t_cmpdatt_F03.F90
+h5ex_t_cmpd_F03_SOURCES = h5ex_t_cmpd_F03.F90
+h5ex_t_Cstring_F03_SOURCES = h5ex_t_Cstring_F03.F90
+h5ex_t_enumatt_F03_SOURCES = h5ex_t_enumatt_F03.F90
+h5ex_t_enum_F03_SOURCES = h5ex_t_enum_F03.F90
+h5ex_t_floatatt_F03_SOURCES = h5ex_t_floatatt_F03.F90
+h5ex_t_float_F03_SOURCES = h5ex_t_float_F03.F90
+h5ex_t_intatt_F03_SOURCES = h5ex_t_intatt_F03.F90
+h5ex_t_int_F03_SOURCES = h5ex_t_int_F03.F90
+h5ex_t_objrefatt_F03_SOURCES = h5ex_t_objrefatt_F03.F90
+h5ex_t_objref_F03_SOURCES = h5ex_t_objref_F03.F90
+h5ex_t_opaqueatt_F03_SOURCES = h5ex_t_opaqueatt_F03.F90
+h5ex_t_opaque_F03_SOURCES = h5ex_t_opaque_F03.F90
+h5ex_t_regrefatt_F03_SOURCES = h5ex_t_regrefatt_F03.F90
+h5ex_t_regref_F03_SOURCES = h5ex_t_regref_F03.F90
+h5ex_t_stringCatt_F03_SOURCES = h5ex_t_stringCatt_F03.F90
+h5ex_t_stringC_F03_SOURCES = h5ex_t_stringC_F03.F90
+h5ex_t_string_F03_SOURCES = h5ex_t_string_F03.F90
+h5ex_t_vlenatt_F03_SOURCES = h5ex_t_vlenatt_F03.F90
+h5ex_t_vlen_F03_SOURCES = h5ex_t_vlen_F03.F90
+
+endif
+
+EXTRA_DIST = tfiles/h5ex_t_arrayatt_F03.tst tfiles/h5ex_t_array_F03.tst tfiles/h5ex_t_bitatt_F03.tst \
+ tfiles/h5ex_t_bit_F03.tst tfiles/h5ex_t_cmpdatt_F03.tst tfiles/h5ex_t_cmpd_F03.tst \
+ tfiles/h5ex_t_Cstring_F03.tst tfiles/h5ex_t_enumatt_F03.tst tfiles/h5ex_t_enum_F03.tst \
+ tfiles/h5ex_t_floatatt_F03.tst tfiles/h5ex_t_float_F03.tst tfiles/h5ex_t_intatt_F03.tst \
+ tfiles/h5ex_t_int_F03.tst tfiles/h5ex_t_objrefatt_F03.tst tfiles/h5ex_t_objref_F03.tst \
+ tfiles/h5ex_t_opaqueatt_F03.tst tfiles/h5ex_t_opaque_F03.tst tfiles/h5ex_t_regrefatt_F03.tst \
+ tfiles/h5ex_t_regref_F03.tst tfiles/h5ex_t_stringCatt_F03.tst tfiles/h5ex_t_stringC_F03.tst \
+ tfiles/h5ex_t_string_F03.tst tfiles/h5ex_t_vlenatt_F03.tst tfiles/h5ex_t_vlen_F03.tst \
+ tfiles/h5ex_t_vlstring.tst \
+ tfiles/h5ex_t_arrayatt_F03.ddl tfiles/h5ex_t_array_F03.ddl tfiles/h5ex_t_bitatt_F03.ddl \
+ tfiles/h5ex_t_bit_F03.ddl tfiles/h5ex_t_cmpdatt_F03.ddl tfiles/h5ex_t_cmpd_F03.ddl \
+ tfiles/h5ex_t_Cstring_F03.ddl tfiles/h5ex_t_enumatt_F03.ddl tfiles/h5ex_t_enum_F03.ddl \
+ tfiles/h5ex_t_floatatt_F03.ddl tfiles/h5ex_t_float_F03.ddl tfiles/h5ex_t_intatt_F03.ddl \
+ tfiles/h5ex_t_int_F03.ddl tfiles/h5ex_t_objrefatt_F03.ddl tfiles/h5ex_t_objref_F03.ddl \
+ tfiles/h5ex_t_opaqueatt_F03.ddl tfiles/h5ex_t_opaque_F03.ddl tfiles/h5ex_t_regrefatt_F03.ddl \
+ tfiles/h5ex_t_regref_F03.ddl tfiles/h5ex_t_stringCatt_F03.ddl tfiles/h5ex_t_stringC_F03.ddl \
+ tfiles/h5ex_t_string_F03.ddl tfiles/h5ex_t_vlenatt_F03.ddl tfiles/h5ex_t_vlen_F03.ddl \
+ tfiles/h5ex_t_vlstring.ddl \
+ test.sh
+
+TESTS = test.sh
+
+CLEANFILES = Makefile test.sh