summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am24
1 files changed, 8 insertions, 16 deletions
diff --git a/Makefile.am b/Makefile.am
index 640fdcb..aaa3b9a 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -73,13 +73,13 @@ else
endif
SUBDIRS = src test $(TESTPARALLEL_DIR) tools . $(CXX_DIR) $(FORTRAN_DIR) \
- $(HDF5_HL_DIR) perform
-DIST_SUBDIRS = src test testpar tools . c++ fortran hl perform examples
+ $(HDF5_HL_DIR)
+DIST_SUBDIRS = src test testpar tools . c++ fortran hl examples
# Some files generated during configure that should be cleaned
DISTCLEANFILES=config/stamp1 config/stamp2
-# Some files/directories generated during check that should be cleaned
+# Some files/directories generated during checkperform that should be cleaned
CHECK_CLEANFILES+=*-tmp
# Define rules for lib, progs, check, and tests.
@@ -93,25 +93,17 @@ lib progs check-p check-s:
fi; \
done
-# Make all, tests, and (un)install also recurse into perform directory
-all-local:
- @cd perform && $(MAKE) $(AM_MAKEFLAGS) all
-
+# Make all, tests, and (un)install also recurse into directory
tests:
- @@SETX@; for d in $(SUBDIRS) perform; do \
+ @@SETX@; for d in $(SUBDIRS); do \
if test $$d != .; then \
(cd $$d && $(MAKE) $(AM_MAKEFLAGS) $@) || exit 1; \
fi; \
- done
-
-install-exec-local:
- @cd perform && $(MAKE) $(AM_MAKEFLAGS) install
-uninstall-local:
- @cd perform && $(MAKE) $(AM_MAKEFLAGS) uninstall
+ done
# Check-clean also recurses into examples directory
check-clean:
- @@SETX@; for d in $(SUBDIRS) examples perform; do \
+ @@SETX@; for d in $(SUBDIRS) examples; do \
if test $$d != .; then \
(cd $$d && $(MAKE) $(AM_MAKEFLAGS) $@) || exit 1; \
fi; \
@@ -201,4 +193,4 @@ check-vfd:
$(top_builddir)/config.status:
# Don't include conclude.am in root Makefile; tests target needs to
-# recurse into perform directory as well as reguar subdirs.
+# recurse into reguar subdirs.