summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rwxr-xr-xMakefile.am5
1 files changed, 5 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index ec07fc7..b6c00fe 100755
--- a/Makefile.am
+++ b/Makefile.am
@@ -137,6 +137,11 @@ uninstall-doc:
installcheck-local:
@(cd examples && $(MAKE) $(AM_MAKEFLAGS) $@) || exit 1;
+# Only source files in the src directory include tracing information,
+# so 'make trace' only needs to recurse into that directory.
+trace:
+ @(cd src && $(MAKE) $(AM_MAKEFLAGS) $@) || exit 1;
+
# Automake wants to make config.status depend on configure. This
# makes sense, but config.status can't always be regenerated
# properly, which can cause builds to fail.