summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rwxr-xr-xMakefile.am9
1 files changed, 9 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index a15e389..58864e0 100755
--- a/Makefile.am
+++ b/Makefile.am
@@ -152,5 +152,14 @@ check-install:
installcheck-local:
(cd examples && $(MAKE) $(AM_MAKEFLAGS) $@) || exit 1;
+# Automake wants to make config.status depend on configure. This
+# makes sense, but config.status can't always be regenerated
+# properly, which can cause builds to fail.
+# This is a problem for our Daily Tests, which need to be able to
+# 'make distclean' reliably before running configure.
+# The simple solution is to override the dependency Automake supplies
+# for config.status so that it will never be regenerated.
+$(top_builddir)/config.status:
+
# Don't include conclude.am in root Makefile; tests target needs to
# recurse into perform directory as well as reguar subdirs.