summaryrefslogtreecommitdiffstats
path: root/c++/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'c++/Makefile.am')
-rw-r--r--c++/Makefile.am8
1 files changed, 7 insertions, 1 deletions
diff --git a/c++/Makefile.am b/c++/Makefile.am
index 94fbefc..92d9f50 100644
--- a/c++/Makefile.am
+++ b/c++/Makefile.am
@@ -18,9 +18,15 @@
include $(top_srcdir)/config/commence.am
+if BUILD_TESTS_CONDITIONAL
+ TEST_DIR = test
+else
+ TEST_DIR=
+endif
+
## Only recurse into subdirectories if C++ interface is enabled.
if BUILD_CXX_CONDITIONAL
- SUBDIRS=src test
+ SUBDIRS=src $(TEST_DIR)
endif
DIST_SUBDIRS = src test examples