summaryrefslogtreecommitdiffstats
path: root/c++/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'c++/configure.in')
-rw-r--r--c++/configure.in9
1 files changed, 9 insertions, 0 deletions
diff --git a/c++/configure.in b/c++/configure.in
index b811450..f4bba77 100644
--- a/c++/configure.in
+++ b/c++/configure.in
@@ -125,6 +125,15 @@ AC_PROG_MAKE_SET
AC_PROG_INSTALL
AM_PROG_LIBTOOL
+dnl ----------------------------------------------------------------------
+dnl Check if they have Perl installed on their system. We only need Perl
+dnl if they're using a GNU compiler.
+dnl
+AC_SUBST(PERL) PERL=""
+if test "X$GCC" = "Xyes"; then
+ AC_CHECK_PROGS(PERL, perl,, $PATH)
+fi
+
if test -z "$AR"; then
AC_CHECK_PROGS(AR,ar xar,:,$PATH)
fi