summaryrefslogtreecommitdiffstats
path: root/c++/examples/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'c++/examples/CMakeLists.txt')
-rw-r--r--c++/examples/CMakeLists.txt27
1 files changed, 27 insertions, 0 deletions
diff --git a/c++/examples/CMakeLists.txt b/c++/examples/CMakeLists.txt
new file mode 100644
index 0000000..1a9602a
--- /dev/null
+++ b/c++/examples/CMakeLists.txt
@@ -0,0 +1,27 @@
+cmake_minimum_required (VERSION 2.8)
+# --------------------------------------------------------------------
+# Notes: When creating examples they should be prefixed
+# with "cpp_ex_". This allows for easier filtering of the examples.
+# --------------------------------------------------------------------
+
+PROJECT (HDF5_CPP_EXAMPLES)
+
+#-----------------------------------------------------------------------------
+# Define examples
+#-----------------------------------------------------------------------------
+
+SET (examples
+ create
+ readdata
+ writedata
+ compound
+ extend_ds
+ chunks
+ h5group
+)
+
+FOREACH (example ${examples})
+ ADD_EXECUTABLE (cpp_ex_${example} ${HDF5_CPP_EXAMPLES_SOURCE_DIR}/${example}.cpp)
+ H5_NAMING (cpp_ex_${example})
+ TARGET_LINK_LIBRARIES (cpp_ex_${example} ${HDF5_CPP_LIB_TARGET} ${HDF5_LIB_TARGET})
+ENDFOREACH (example ${examples})