summaryrefslogtreecommitdiffstats
path: root/c++/examples/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'c++/examples/Makefile.am')
-rw-r--r--c++/examples/Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/c++/examples/Makefile.am b/c++/examples/Makefile.am
index 671dde6..4a76380 100644
--- a/c++/examples/Makefile.am
+++ b/c++/examples/Makefile.am
@@ -36,6 +36,10 @@ EXTRA_PROG=$(TEST_PROG)
INSTALL_FILES=create.cpp readdata.cpp writedata.cpp compound.cpp \
extend_ds.cpp chunks.cpp h5group.cpp
+# Some of the examples depend on files created by running other examples
+readdata.chkexe_: create.chkexe_
+chunks.chkexe_: extend_ds.chkexe_
+
# These are the files that 'make clean' (and derivatives) will remove from this
# directory. Since automake doesn't know about the examples, we need to
# tell it to clean the example programs, too.