summaryrefslogtreecommitdiffstats
path: root/c++/examples/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'c++/examples/Makefile.am')
-rw-r--r--c++/examples/Makefile.am7
1 files changed, 7 insertions, 0 deletions
diff --git a/c++/examples/Makefile.am b/c++/examples/Makefile.am
index 995964b..d729521 100644
--- a/c++/examples/Makefile.am
+++ b/c++/examples/Makefile.am
@@ -61,6 +61,13 @@ install-data-local:
uninstall-local:
@$(MAKE) uninstall-examples
+# Some C++ compilers/linkers will create a directory named ii_files,
+# which should be cleaned.
+mostlyclean-local:
+ if test -d ii_files; then \
+ $(RM) -rf ii_files; \
+ fi
+
# Install source files, which are the examples with .cpp suffixes. Do the same
# for uninstall.
install-examples: $(EXAMPLEDIR)