summaryrefslogtreecommitdiffstats
path: root/c++/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'c++/src/Makefile.am')
-rw-r--r--c++/src/Makefile.am8
1 files changed, 4 insertions, 4 deletions
diff --git a/c++/src/Makefile.am b/c++/src/Makefile.am
index daab94e..08cd88d 100644
--- a/c++/src/Makefile.am
+++ b/c++/src/Makefile.am
@@ -22,13 +22,13 @@ include $(top_srcdir)/config/commence.am
# Include src directory
INCLUDES=-I$(top_srcdir)/src
-# This is our main target
-lib_LTLIBRARIES=libhdf5_cpp.la
-
# Build the library statically because some compliers can only link one
# dynamic library, and that's the main hdf5 library (which is much larger
# than this one).
-libhdf5_cpp_la_LDFLAGS=-static
+AM_LDFLAGS=-static
+
+# This is our main target
+lib_LTLIBRARIES=libhdf5_cpp.la
bin_SCRIPTS=h5c++