summaryrefslogtreecommitdiffstats
path: root/c++/test/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'c++/test/Makefile.am')
-rw-r--r--c++/test/Makefile.am8
1 files changed, 8 insertions, 0 deletions
diff --git a/c++/test/Makefile.am b/c++/test/Makefile.am
index a4c2cfc..43194e5 100644
--- a/c++/test/Makefile.am
+++ b/c++/test/Makefile.am
@@ -39,4 +39,12 @@ testhdf5_SOURCES=testhdf5.cpp tattr.cpp tfile.cpp th5s.cpp h5cpputil.cpp
# Tell conclude.am that these are C++ tests.
HDF_CXX=yes
+# Some C++ compilers/linkers (PGI?) create a directory named "ii_files" that
+# holds *.ii files, which are template entity instantiations.
+# This entire directory should be cleaned.
+mostlyclean-local:
+ if test -d ii_files; then \
+ $(RM) -rf ii_files; \
+ fi
+
include $(top_srcdir)/config/conclude.am