summaryrefslogtreecommitdiffstats
path: root/c++/test/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'c++/test/Makefile.am')
-rw-r--r--c++/test/Makefile.am6
1 files changed, 6 insertions, 0 deletions
diff --git a/c++/test/Makefile.am b/c++/test/Makefile.am
index 2f5edf5..35de101 100644
--- a/c++/test/Makefile.am
+++ b/c++/test/Makefile.am
@@ -22,6 +22,12 @@ include $(top_srcdir)/config/commence.am
# Include src, test, and c++/src directories
INCLUDES=-I$(top_srcdir)/src -I$(top_srcdir)/test -I$(top_srcdir)/c++/src
+# Shared C++ libraries aren't universally supported.
+if CXX_SHARED_CONDITIONAL
+else
+ AM_LDFLAGS=-static
+endif
+
# These are our main targets. They should be listed in the order to be
# executed, generally most specific tests to least specific tests.
TEST_PROG=dsets testhdf5