summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac50
1 files changed, 25 insertions, 25 deletions
diff --git a/configure.ac b/configure.ac
index 52c77e5..f79b485 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1866,7 +1866,7 @@ if test "X-$DEBUG_PKG" = X- ; then
fi
AC_SUBST([DEBUG_PKG])
-all_packages="ac,b,b2,d,e,f,g,hg,hl,i,mf,mm,o,p,s,t,v,z"
+all_packages="ac,b2,d,e,f,g,hg,hl,i,mf,mm,o,p,s,t,v,z"
case "X-$DEBUG_PKG" in
X-yes)
DEBUG_PKG="d,e,f,g,hg,i,mm,o,p,s,t,v,z"
@@ -2071,30 +2071,30 @@ esac
## Check if they would like to enable the internal memory allocation sanity
## checking code.
##
-##AC_SUBST([MEMORYALLOCSANITYCHECK])
-##AC_MSG_CHECKING([whether internal memory allocation sanity checking is used])
-##AC_ARG_ENABLE([memory-alloc-sanity-check],
-## [AS_HELP_STRING([--enable-memory-alloc-sanity-check],
-## [Enable this option to turn on internal memory
-## allocation sanity checking. This could cause
-## more memory use and somewhat slower allocation.
-## This option is orthogonal to the
-## --enable-using-memchecker option.
-## Default=no.])],
-## [MEMORYALLOCSANITYCHECK=$enableval])
-##
-##case "X-$MEMORYALLOCSANITYCHECK" in
-## X-yes)
-## MEMORYALLOCSANITYCHECK=yes
-## AC_MSG_RESULT([yes])
-## AC_DEFINE([MEMORY_ALLOC_SANITY_CHECK], [1],
-## [Define to enable internal memory allocation sanity checking.])
-## ;;
-## *)
-## MEMORYALLOCSANITYCHECK=no
-## AC_MSG_RESULT([no])
-## ;;
-##esac
+AC_SUBST([MEMORYALLOCSANITYCHECK])
+AC_MSG_CHECKING([whether internal memory allocation sanity checking is used])
+AC_ARG_ENABLE([memory-alloc-sanity-check],
+ [AS_HELP_STRING([--enable-memory-alloc-sanity-check],
+ [Enable this option to turn on internal memory
+ allocation sanity checking. This could cause
+ more memory use and somewhat slower allocation.
+ This option is orthogonal to the
+ --enable-using-memchecker option.
+ Default=no.])],
+ [MEMORYALLOCSANITYCHECK=$enableval])
+
+case "X-$MEMORYALLOCSANITYCHECK" in
+ X-yes)
+ MEMORYALLOCSANITYCHECK=yes
+ AC_MSG_RESULT([yes])
+ AC_DEFINE([MEMORY_ALLOC_SANITY_CHECK], [1],
+ [Define to enable internal memory allocation sanity checking.])
+ ;;
+ *)
+ MEMORYALLOCSANITYCHECK=no
+ AC_MSG_RESULT([no])
+ ;;
+esac
## Checkpoint the cache
AC_CACHE_SAVE