summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 7b313e0..6a1ab73 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1945,7 +1945,7 @@ AC_ARG_WITH([pthread],
case "$withval" in
yes)
AC_CHECK_HEADERS([pthread.h],, [unset HAVE_PTHREAD])
- if test "x$HAVE_DMALLOC" = "xyes"; then
+ if test "x$HAVE_PTHREAD" = "xyes"; then
AC_CHECK_LIB([pthread], [pthread_self],, [unset HAVE_PTHREAD])
fi
;;
@@ -1987,7 +1987,7 @@ case "$withval" in
AC_CHECK_HEADERS([pthread.h],, [unset HAVE_PTHREAD])
fi
- if test "x$HAVE_DMALLOC" = "xyes"; then
+ if test "x$HAVE_PTHREAD" = "xyes"; then
if test -n "$pthread_lib"; then
saved_LDFLAGS="$LDFLAGS"
saved_AM_LDFLAGS="$AM_LDFLAGS"