summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac35
1 files changed, 21 insertions, 14 deletions
diff --git a/configure.ac b/configure.ac
index ff0f284..0a1370f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -24,7 +24,7 @@ AC_PREREQ([2.69])
## NOTE: Do not forget to change the version number here when we do a
## release!!!
##
-AC_INIT([HDF5], [1.11.2], [help@hdfgroup.org])
+AC_INIT([HDF5], [1.11.4], [help@hdfgroup.org])
AC_CONFIG_SRCDIR([src/H5.c])
AC_CONFIG_HEADERS([src/H5config.h])
@@ -1261,8 +1261,8 @@ AC_ARG_WITH([dmalloc],
[Use dmalloc memory debugging aid [default=no]])],,
[withval=no])
-case $withval in
- yes)
+case "X-$withval" in
+ X-yes)
HAVE_DMALLOC="yes"
AC_CHECK_HEADERS([dmalloc.h],, [unset HAVE_DMALLOC])
if test "x$HAVE_DMALLOC" = "xyes"; then
@@ -1272,7 +1272,7 @@ case $withval in
AC_MSG_ERROR([couldn't find dmalloc library])
fi
;;
- no)
+ X-|X-no|X-none)
HAVE_DMALLOC="no"
AC_MSG_CHECKING([for dmalloc library])
AC_MSG_RESULT([suppressed])
@@ -1340,8 +1340,8 @@ AC_ARG_WITH([zlib],
filter [default=yes]])],,
[withval=yes])
-case $withval in
- yes)
+case "X-$withval" in
+ X-yes)
HAVE_ZLIB="yes"
AC_CHECK_HEADERS([zlib.h], [HAVE_ZLIB_H="yes"], [unset HAVE_ZLIB])
if test "x$HAVE_ZLIB" = "xyes" -a "x$HAVE_ZLIB_H" = "xyes"; then
@@ -1355,7 +1355,7 @@ case $withval in
AC_CHECK_FUNC([compress2], [HAVE_COMPRESS2="yes"])
fi
;;
- no)
+ X-|X-no|X-none)
HAVE_ZLIB="no"
AC_MSG_CHECKING([for zlib])
AC_MSG_RESULT([suppressed])
@@ -1434,8 +1434,8 @@ AC_ARG_WITH([szlib],
filter [default=no]])],,
[withval=no])
-case $withval in
- yes)
+case "X-$withval" in
+ X-yes)
HAVE_SZLIB="yes"
AC_CHECK_HEADERS([szlib.h], [HAVE_SZLIB_H="yes"], [unset HAVE_SZLIB])
if test "x$HAVE_SZLIB" = "xyes" -a "x$HAVE_SZLIB_H" = "xyes"; then
@@ -1445,7 +1445,7 @@ case $withval in
AC_MSG_ERROR([couldn't find szlib library])
fi
;;
- no)
+ X-|X-no|X-none)
HAVE_SZLIB="no"
AC_MSG_CHECKING([for szlib])
AC_MSG_RESULT([suppressed])
@@ -3191,10 +3191,10 @@ esac
AC_SUBST([DEFAULT_API_VERSION])
AC_MSG_CHECKING([which version of public symbols to use by default])
AC_ARG_WITH([default-api-version],
- [AS_HELP_STRING([--with-default-api-version=(v16|v18|v110)],
+ [AS_HELP_STRING([--with-default-api-version=(v16|v18|v110|v112)],
[Specify default release version of public symbols
- [default=v110]])],,
- [withval=v110])
+ [default=v112]])],,
+ [withval=v112])
if test "X$withval" = "Xv16"; then
AC_MSG_RESULT([v16])
@@ -3209,6 +3209,13 @@ elif test "X$withval" = "Xv18"; then
elif test "X$withval" = "Xv110"; then
AC_MSG_RESULT([v110])
DEFAULT_API_VERSION=v110
+ AC_DEFINE([USE_110_API_DEFAULT], [1],
+ [Define using v1.10 public API symbols by default])
+elif test "X$withval" = "Xv112"; then
+ AC_MSG_RESULT([v112])
+ DEFAULT_API_VERSION=v112
+ AC_DEFINE([USE_112_API_DEFAULT], [1],
+ [Define using v1.12 public API symbols by default])
else
AC_MSG_ERROR([invalid version of public symbols given])
fi
@@ -3218,7 +3225,7 @@ fi
## if the user insists on doing this via the --enable-unsupported configure
## flag, we'll let them.
if test "X${ALLOW_UNSUPPORTED}" != "Xyes"; then
- if test "X${DEFAULT_API_VERSION}" != "Xv110" -a "X${DEPRECATED_SYMBOLS}" = "Xno" ; then
+ if test "X${DEFAULT_API_VERSION}" != "Xv112" -a "X${DEPRECATED_SYMBOLS}" = "Xno" ; then
AC_MSG_ERROR([Removing old public API symbols not allowed when using them as default public API symbols. Use --enable-unsupported to override this error.])
fi
fi