summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 3 insertions, 11 deletions
diff --git a/configure.ac b/configure.ac
index d31dd6d..163f6d3 100644
--- a/configure.ac
+++ b/configure.ac
@@ -585,11 +585,11 @@ if test "X$HDF_FORTRAN" = "Xyes"; then
AC_DEFINE([FORTRAN_HAVE_STORAGE_SIZE], [1], [Define if we have Fortran intrinsic STORAGE_SIZE])
fi
- if test "X$HAVE_C_SIZEOF_FORTRAN" = "Xyes"; then
+ if test "X$HAVE_C_SIZEOF_FORTRAN" = "Xyes"; then
AC_DEFINE([FORTRAN_HAVE_C_SIZEOF], [1], [Define if we have Fortran intrinsic C_SIZEOF])
fi
- if test "X$HAVE_SIZEOF_FORTRAN" = "Xyes"; then
+ if test "X$HAVE_SIZEOF_FORTRAN" = "Xyes"; then
AC_DEFINE([FORTRAN_HAVE_SIZEOF], [1], [Define if we have Fortran intrinsic SIZEOF])
fi
@@ -604,7 +604,7 @@ if test "X$HDF_FORTRAN" = "Xyes"; then
## Is C_LONG_DOUBLE different from C_DOUBLE
FORTRAN_C_LONG_DOUBLE_IS_UNIQUE="0"
- if test "X$FORTRAN_HAVE_C_LONG_DOUBLE"; then
+ if test "$FORTRAN_HAVE_C_LONG_DOUBLE" = "1"; then
PAC_PROG_FC_C_LONG_DOUBLE_EQ_C_DOUBLE
if test "X$C_LONG_DOUBLE_IS_UNIQUE_FORTRAN" = "Xyes"; then
FORTRAN_C_LONG_DOUBLE_IS_UNIQUE="1"
@@ -3343,14 +3343,6 @@ fi
##
AM_CONDITIONAL([HAVE_SHARED_CONDITIONAL], [test "X$enable_shared" = "Xyes"])
-## The H5 flags go through multiple rounds of processing, which can introduce
-## extra whitespace. Trim this for nicer output in the settings file.
-H5_LDFLAGS=$(echo "$H5_LDFLAGS" | awk '$1=$1')
-H5_CPPFLAGS=$(echo "$H5_CPPFLAGS" | awk '$1=$1')
-H5_CFLAGS=$(echo "$H5_CFLAGS" | awk '$1=$1')
-H5_FCFLAGS=$(echo "$H5_FCFLAGS" | awk '$1=$1')
-H5_CXXFLAGS=$(echo "$H5_CXXFLAGS" | awk '$1=$1')
-
AC_CONFIG_FILES([src/libhdf5.settings
Makefile
src/Makefile