summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index c37a1c4..b4be127 100644
--- a/configure.ac
+++ b/configure.ac
@@ -33,8 +33,8 @@ AC_INIT([HDF5], [1.9.227], [help@hdfgroup.org])
## Requirement #1: Check if Perl is installed.
##
AC_SUBST([PERL]) PERL=""
-AC_CHECK_PROG([PERL], [perl],, [$PATH])
-if test "x$PERL" = "xfalse"; then
+AC_CHECK_PROG([PERL], [perl], true, false, [$PATH])
+if test "x$PERL" != "xtrue"; then
AC_MSG_ERROR([*** Perl is required for installing HDF5, but Perl could not be found!])
fi