summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 5 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 5ba01c6..a6d1192 100644
--- a/configure.ac
+++ b/configure.ac
@@ -695,12 +695,14 @@ if test "X$HDF_CXX" = "Xyes"; then
## Checking if C++ can handle namespaces
PAC_PROG_CXX_NAMESPACE
- ## Checking if C++ has offsetof extension
- PAC_PROG_CXX_OFFSETOF
-
## if C++ can handle static cast
PAC_PROG_CXX_STATIC_CAST
+ ## Checking if C++ has offsetof extension,
+ ## note: this test has to be the last of the C++ tests because it sets a definition
+ ## which would be used in the other tests, causing them to fail.
+ PAC_PROG_CXX_OFFSETOF
+
else
AC_MSG_RESULT([no])
CXX="no"