summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 9 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index ccf5dc5..e1fee46 100644
--- a/configure.ac
+++ b/configure.ac
@@ -3116,5 +3116,14 @@ cat >> src/H5config.h <<EOF
#endif
EOF
+## HDF5 configure code created by autotools with gcc 4.9.2 is adding problematic
+## linker flags: -l with no library name; -l <libname>, specifically gfortran or m.
+## This sed script corrects "-l <libname>" first and then "-l " with no library name.
+## If the order is not preserved, all instances of "-l " will be removed.
+## The -i option for sed doesn't work on some systems, so a temporary file is used
+## and used to overwrite the original libtool file.
+sed -e '/^postdeps/ s/-l \([a-zA-Z]\)/-l\1/g' -e '/^postdeps/ s/-l //g' libtool > libtool_rev
+mv -f libtool_rev libtool
+
## show the configure settings
cat src/libhdf5.settings