summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 5 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 0d9d79e..4564a0f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -24,7 +24,7 @@ AC_PREREQ([2.69])
## NOTE: Do not forget to change the version number here when we do a
## release!!!
##
-AC_INIT([HDF5], [1.8.20-pre1], [help@hdfgroup.org])
+AC_INIT([HDF5], [1.8.20-pre2], [help@hdfgroup.org])
AC_CONFIG_SRCDIR([src/H5.c])
AC_CONFIG_HEADERS([src/H5config.h])
@@ -777,6 +777,8 @@ fi
## ----------------------------------------------------------------------
## Production flags? Save the value in $CONFIG_MODE so we have it for
## the record.
+## To switch the default between production and development, move X-|
+## to X-yes) or X-no)
##
AC_MSG_CHECKING([for production mode])
AC_ARG_ENABLE([production],
@@ -784,7 +786,7 @@ AC_ARG_ENABLE([production],
[Determines how to run the compiler.])])
case "X-$enable_production" in
- X-yes)
+ X-|X-yes)
enable_production="yes"
AC_MSG_RESULT([production])
CONFIG_MODE=production
@@ -793,7 +795,7 @@ case "X-$enable_production" in
H5_CXXFLAGS="$H5_CXXFLAGS $PROD_CXXFLAGS"
H5_FCFLAGS="$H5_FCFLAGS $PROD_FCFLAGS"
;;
- X-|X-no)
+ X-no)
enable_production="no"
AC_MSG_RESULT([development])
CONFIG_MODE=development