summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac27
1 files changed, 26 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 108526c..82e71d0 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1058,12 +1058,15 @@ if test "X$STATIC_EXEC" = "Xyes"; then
## Issue a warning if -static flag is not supported.
if test "X$lt_cv_prog_compiler_static_works" = "Xno"; then
echo " warning: -static flag not supported on this system; executable won't statically link shared system libraries."
+ LT_STATIC_EXEC=""
+ else
+ LT_STATIC_EXEC="-all-static"
fi
- LT_STATIC_EXEC="-all-static"
else
echo "no"
LT_STATIC_EXEC=""
fi
+AM_CONDITIONAL([USE_PLUGINS_CONDITIONAL], [test "X$LT_STATIC_EXEC" = X])
AC_SUBST([LT_STATIC_EXEC])
@@ -3126,6 +3129,27 @@ fi
AM_CONDITIONAL([DIRECT_VFD_CONDITIONAL], [test "X$DIRECT_VFD" = "Xyes"])
## ----------------------------------------------------------------------
+## Enable custom plugin default path for library. It requires SHARED support.
+##
+AC_MSG_CHECKING([for custom plugin default path definition])
+AC_ARG_WITH([default-plugindir],
+ [AS_HELP_STRING([--with-default-plugindir=location],
+ [Specify default location for plugins
+ [default="/usr/local/hdf5/lib/plugin"]])],,
+ withval="/usr/local/hdf5/lib/plugin")
+
+if test "X$withval" = "X"; then
+ AC_MSG_RESULT([default])
+ default_plugindir="/usr/local/hdf5/lib/plugin"
+else
+ AC_MSG_RESULT([$withval])
+ default_plugindir=$withval
+fi
+
+AC_DEFINE_UNQUOTED([DEFAULT_PLUGINDIR], ["$default_plugindir"],
+ [Define the default plugins path to compile])
+
+## ----------------------------------------------------------------------
## Decide whether the presence of user's exception handling functions is
## checked and data conversion exceptions are returned. This is mainly
## for the speed optimization of hard conversions. Soft conversions can
@@ -4545,6 +4569,7 @@ AC_CONFIG_FILES([src/libhdf5.settings
tools/h5jam/testh5jam.sh
tools/h5repack/Makefile
tools/h5repack/h5repack.sh
+ tools/h5repack/h5repack_plugin.sh
tools/h5ls/Makefile
tools/h5copy/Makefile
tools/h5copy/testh5copy.sh