summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 9 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 31578a6..556e565 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1122,6 +1122,12 @@ else
AC_MSG_RESULT([no])
fi
+## These need to be exposed for some tests.
+AC_SUBST([H5_UTILS_TEST_BUILDDIR])
+H5_UTILS_TEST_BUILDDIR='utils/test'
+AC_SUBST([H5_TEST_BUILDDIR])
+H5_TEST_BUILDDIR='test'
+
## ----------------------------------------------------------------------
## Check if they would like to disable building tools
##
@@ -1686,7 +1692,7 @@ fi
## command-line switch. The value is an include path and/or a library path.
## If the library path is specified then it must be preceded by a comma.
##
-AC_SUBST([LL_PATH])
+AC_SUBST([LL_PATH])
AC_SUBST([USE_FILTER_SZIP]) USE_FILTER_SZIP="no"
AC_ARG_WITH([szlib],
[AS_HELP_STRING([--with-szlib=DIR],
@@ -3037,7 +3043,7 @@ if test -n "$PARALLEL"; then
fi
## ----------------------------------------------------------------------
-## Build parallel tools if parallel tools, parallel, and build tools options
+## Build parallel tools if parallel tools, parallel, and build tools options
## are all enabled.
##
AC_SUBST([PARALLEL_TOOLS])
@@ -3057,7 +3063,7 @@ if test "X${PARALLEL_TOOLS}" = "Xyes"; then
AC_MSG_ERROR([--enable-tools is required for --enable-parallel-tools])
fi
if test "X${PARALLEL}" != "Xyes"; then
- AC_MSG_ERROR([--enable-parallel is required for --enable-parallel-tools])
+ AC_MSG_ERROR([--enable-parallel is required for --enable-parallel-tools])
fi
fi