summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in13
1 files changed, 13 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 070f9ee..aee6bba 100644
--- a/configure.in
+++ b/configure.in
@@ -2468,6 +2468,19 @@ case "X-$enable_parallel" in
fi
dnl Set RUNPARALLEL to mpirun if not set yet.
+ dnl Check for building on Cray if RUNPARALLEL is not yet set by checking
+ dnl for 'aprun' command (which is the parallel job launcher, like mpirun).
+ if test "X$PARALLEL" = "Xyes" -a -z "$RUNPARALLEL"; then
+ dnl Find the path where aprun is located.
+ for path in `echo $PATH | ${TR} ":" " "`; do
+ if test -x $path/aprun; then
+ RUNPARALLEL="aprun -q -n \$\${NPROCS:=3}"
+ break;
+ fi
+ done
+ fi
+
+ dnl Set RUNPARALLEL to mpirun if not set yet.
if test "X$PARALLEL" = "Xyes" -a -z "$RUNPARALLEL"; then
RUNPARALLEL="mpirun -np \$\${NPROCS:=3}"
fi