summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in6
1 files changed, 5 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 4c3b3db..af929fe 100644
--- a/configure.in
+++ b/configure.in
@@ -1871,7 +1871,7 @@ AC_ARG_ENABLE([filters],
AC_SUBST([FILTERS])
dnl Eventually: all_filters="shuffle,foo,bar,baz"
-all_filters="shuffle"
+all_filters="shuffle,adler32"
case "X-$FILTERS" in
X-|X-all)
FILTERS=$all_filters
@@ -1896,6 +1896,10 @@ dnl
AC_DEFINE(HAVE_FILTER_SHUFFLE, 1,
[Define if support for shuffle filter is enabled])
fi
+ if test $filter = "ADLER32"; then
+ AC_DEFINE(HAVE_FILTER_ADLER32, 1,
+ [Define if support for Adler32 checksum is enabled])
+ fi
done
fi