summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in7
1 files changed, 5 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index 2e366e9..4af6591 100644
--- a/configure.in
+++ b/configure.in
@@ -2152,8 +2152,11 @@ case "X-$enable_parallel" in
AC_MSG_RESULT([provided by compiler])
PARALLEL=yes
- dnl Try link a simple MPI program. If fail, try again with -lmpi.
- AC_TRY_LINK(, MPI_Init(),, AC_CHECK_LIB(mpi, MPI_Init,, PARALLEL=no))
+ dnl Try link a simple MPI program. If fail, try again with -lmpi and
+ dnl -lmpich.
+ AC_TRY_LINK(, MPI_Init(),, \
+ AC_CHECK_LIB(mpi, MPI_Init,, \
+ AC_CHECK_LIB(mpich, MPI_Init,, PARALLEL=no)))
dnl Then try link a simple MPI-IO program. If fail, try again with
dnl -lmpio.