summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in19
1 files changed, 19 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 221415d..901f3fb 100644
--- a/configure.in
+++ b/configure.in
@@ -662,6 +662,25 @@ case "$CC_BASENAME" in
PARALLEL="$CC_BASENAME"
;;
+ cmpicc)
+ dnl The ChaMPIon compiler on NCSA tungsten. The cmpirun command on tungsten
+ dnl isn't in the same path as cmpicc.
+ PARALLEL=cmpicc
+ AC_MSG_CHECKING([for cmpirun])
+
+ dnl Is there an cmpirun?
+ if test -x cmpirun; then
+ AC_MSG_RESULT([cmpirun])
+ RUNSERIAL="${RUNSERIAL:-none}"
+
+ if test -z "$RUNPARALLEL"; then
+ RUNPARALLEL="cmpirun -np \$\${NPROCS:=3}"
+ fi
+ else
+ AC_MSG_RESULT([none])
+ fi
+ ;;
+
*)
dnl Probably not a parallel compiler, but if `--enable-parallel'
dnl is defined below then we're still building a parallel hdf5.