summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in17
1 files changed, 17 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index edb848c..ef31a23 100644
--- a/configure.in
+++ b/configure.in
@@ -3244,6 +3244,23 @@ else
fi
dnl ----------------------------------------------------------------------
+dnl Set the flag to indicate that the machine generates bad code
+dnl for the H5V_log2_gen() routine in src/H5Vprivate.h
+dnl (This flag should be set to no for all machines, except for SGI IRIX64,
+dnl where the cache value is set to yes in it's config file)
+dnl
+AC_MSG_CHECKING([if bad code for log2 routine is generated])
+AC_CACHE_VAL([hdf5_cv_bad_log2_code_generated], [hdf5_cv_bad_log2_code_generated=no])
+
+if test ${hdf5_cv_bad_log2_code_generated} = "yes"; then
+ AC_DEFINE([BAD_LOG2_CODE_GENERATED], [1],
+ [Define if your system generates wrong code for log2 routine.])
+ AC_MSG_RESULT([yes])
+else
+ AC_MSG_RESULT([no])
+fi
+
+dnl ----------------------------------------------------------------------
dnl Set some variables for general configuration information to be saved
dnl and installed with the libraries.
dnl