summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in7
1 files changed, 6 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index a5a72fe..1686261 100644
--- a/configure.in
+++ b/configure.in
@@ -107,7 +107,12 @@ AC_TYPE_SIZE_T
dnl ----------------------------------------------------------------------
dnl Check for functions.
dnl
-AC_CHECK_FUNCS(lseek64 fseek64 getpwuid gethostname)
+AC_CHECK_FUNCS(getpwuid gethostname)
+
+AC_TRY_COMPILE([#include<sys/types.h>],
+ [off64_t n = 0;],
+ AC_CHECK_FUNCS(lseek64 fseek64),
+ AC_MSG_RESULT([skipping test for lseek64() and fseek64()]))
dnl ----------------------------------------------------------------------