summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in9
1 files changed, 9 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index be8f2b4..d24dabc 100644
--- a/configure.in
+++ b/configure.in
@@ -791,6 +791,15 @@ if test "X${HDF_CXX}" = "Xyes" && test "X${enable_shared}" != "Xno"; then
H5_CXX_SHARED="no"
fi
+dnl Try to detect the +DD64 flag for HPUX aCC compiler and disable C++ shared libraries if it's
+dnl being used.
+
+ if (echo dummy ${CXX} ${CXXLD} ${CFLAGS} ${CXXFLAGS} ${LDFLAGS} | grep 'DD64') > /dev/null; then
+ echo " warning: +DD64 flag detected"
+ echo " disabling shared C++ libraries"
+ H5_CXX_SHARED="no"
+ fi
+
if test "X${enable_static}" = "Xno" && test "X${H5_CXX_SHARED}" = "Xno"; then
AC_MSG_ERROR([both static and shared C++ libraries are disabled])
fi