summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in9
1 files changed, 9 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 0b40d41..8aa0144 100644
--- a/configure.in
+++ b/configure.in
@@ -218,6 +218,15 @@ fi
AC_SUBST(LT_STATIC_EXEC)
dnl ----------------------------------------------------------------------
+dnl Check if they have Perl installed on their system. We only need Perl
+dnl if they're using a GNU compiler.
+dnl
+AC_SUBST(PERL) PERL=""
+if test "X$GCC" = "Xyes"; then
+ AC_CHECK_PROGS(PERL, perl,, $PATH)
+fi
+
+dnl ----------------------------------------------------------------------
dnl Check which archiving tool to use. This needs to be done before
dnl the AM_PROG_LIBTOOL macro.
dnl