summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in18
1 files changed, 16 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index ff9ded5..ee19951 100644
--- a/configure.in
+++ b/configure.in
@@ -2060,13 +2060,27 @@ AC_TRY_COMPILE(,[int __attribute__((unused)) x],
AC_MSG_CHECKING([for __func__ extension])
AC_TRY_COMPILE(,[ const char *fname = __func__; ],
AC_DEFINE([HAVE_C99_FUNC], [1],
- [Define if the compiler understand the __func__ keyword])
+ [Define if the compiler understands the __func__ keyword])
AC_MSG_RESULT([yes]),
AC_MSG_RESULT([no]))
AC_MSG_CHECKING([for __FUNCTION__ extension])
AC_TRY_COMPILE(,[ const char *fname = __FUNCTION__; ],
AC_DEFINE([HAVE_FUNCTION], [1],
- [Define if the compiler understand the __FUNCTION__ keyword])
+ [Define if the compiler understands the __FUNCTION__ keyword])
+ AC_MSG_RESULT([yes]),
+ AC_MSG_RESULT([no]))
+AC_MSG_CHECKING([for C99 designated initialization support])
+AC_TRY_COMPILE(,[
+ typedef struct {
+ int x;
+ union {
+ int i;
+ double d;
+ } u;
+ } di_struct_t;
+ di_struct_t x = {0, { .d = 0.0}}; ],
+ AC_DEFINE([HAVE_C99_DESIGNATED_INITIALIZER], [1],
+ [Define if the compiler understands C99 designated initialization of structs and unions])
AC_MSG_RESULT([yes]),
AC_MSG_RESULT([no]))