summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in12
1 files changed, 8 insertions, 4 deletions
diff --git a/configure.in b/configure.in
index 9cd621b..faa8108 100644
--- a/configure.in
+++ b/configure.in
@@ -13,8 +13,7 @@ AC_INIT(src/H5.c)
AC_CONFIG_HEADER(src/H5config.h)
AC_CONFIG_AUX_DIR(bin)
AC_CANONICAL_HOST
-
-
+AC_SUBST(CPPFLAGS)
dnl ----------------------------------------------------------------------
dnl Check that the cache file was build on the same host as what we're
@@ -65,7 +64,6 @@ if test $site_config != "none"; then
fi
-
dnl ----------------------------------------------------------------------
dnl Check for programs.
dnl
@@ -107,6 +105,12 @@ AC_TYPE_SIZE_T
dnl ----------------------------------------------------------------------
+dnl Check for functions.
+dnl
+AC_CHECK_FUNCS(lseek64 fseek64)
+
+
+dnl ----------------------------------------------------------------------
dnl Check sizes of various integral data types.
dnl
AC_C_BIGENDIAN
@@ -166,7 +170,7 @@ case "X-$PARALLEL" in
AC_DEFINE(PHDF5) dnl THIS WILL GO AWAY SHORTLY!!!
AC_DEFINE(HAVE_PARALLEL)
PARALLEL_SRC='$(PARALLEL_SRC)'
- CFLAGS="$CFLAGS $MPI_INC"
+ CPPFLAGS="$CPPFLAGS $MPI_INC"
CFLAGS="$CFLAGS $MPI_LIB"
AC_CHECK_LIB(mpi,main) dnl Replace `main' with some function
AC_CHECK_LIB(mpio,main) dnl Replace `main' with some function